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INSTALLING THE QSALESDATA SOFTWARE 
1. We recommend performing your first install on the computer/server that hosts your ACT! database if 

you are going to be in a multi-user system.  If you are a single user, go to the computer that you want 
to run the QSalesData software.  Close out of ACT! and QuickBooks if either are open. 

2. Go to www.QSalesData.com/install  
3. Before doing anything else, select and print the  appropriate Checklist Document from the 

Install Page you now have open.  There will be one for Single User and Multi User installs.  
This Checklist document will guide you through the QSalesData installation process, and 
make sure you don’t miss any installation steps. 

4. Download and run the appropriate QSalesData install file for your version of ACT!. 
5. When you get the Components to Install screen, choose the appropriate components to install.  If the 

user is a QuickBooks user as well, you want to install both components.  If the user is not a 
QuickBooks user, and you just want to give them the QB Transactions Tab functionality, then 
uncheck the Import Components option, and install only the Display Components. 

 

 
 
6. If you are installing QSalesData for the first time on this machine, click on YES to Install the 

Connector Library files.  If you are upgrading, click on NO. 
 

 
 
7. If you get prompted to Modify, Repair or Remove, choose the REPAIR option and click on Next. 
8. Click on INSTALL. 
9. Click on FINISH, and the installation is complete. 
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LICENSING THE QSALESDATA PRODUCT 
 
The QSalesData software will run in trial mode for 15 days when you first install it.  While in Trial Mode, 
the software will have full functionality.  After 15 days you will need to purchase a license, or the software 
will no longer run.  You need a license for each physical workstation that will be running the QSalesData 
software.  The first time you open ACT! after installing the Q SalesData product you will be 
prompted with the following screen.  
 

  
 
You can run the software in Trial Mode by clicking on the TRY button.  After you have purchased your 
licenses, you can click on the REGISTER button to enter in your Serial Number and Company information 
and activate your license.  When you click on REGISTER, you will get the following window: 
 

 
 
When you click on REGISTER the program will go out to the Internet and verify and activate your Serial 
Number.  Once activated, ACT! will start up, and the QSalesData software is ready for use. 

You can run the software in 
Trial Mode for up to 15 days by 
clicking on the TRY button.   
When you have purchased your 
licenses you can click on the 
REGISTER button to enter your 
serial numbers.  

Fill out your specific Company 
and Contact information, enter 
in the Serial Number provided 
to you and click on the 
REGISTER button.  NOTE: You 
need an Internet Connection for 
the license to activate.  
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BUILD QSALESDATA FIELDS IN ACT – STEP 2 OF INSTALL CHECKLIST 
 
There is a series of fields that need to be created in order for the QSalesData product to work properly.  
We have created a program that will build these ACT fields for you.    Note:  This process will take 
between 5-10 minutes to complete. 
 
1. In ACT, go to File > Backup > Database, and make a current backup of your ACT! database. 
2. In ACT, go to View > Contacts then go to Tools > QSalesData Import 
3. Click on the BUILD FIELDS button and say YES to continue.   
4. You will get the following window.  Select the field sections you want to build and enter in the login 

info for an ACT user that has administrator rights. 
 

  
 
5. Once you have the appropriate check boxes selected and your ACT Login information entered, go 

ahead and click on the BUILD FIELDS button and the QSalesData program will build the appropriate 
fields in your ACT database. 

 

Building the Contact and Custom Table 
fields is mandatory.  Building Years 4/5 is 
optional.  You only need to build the 
company fields if you plan on using 
Company Records in ACT and you want to 
see sales fields there. 

Building the Opportunity fields only applies 
if you are running ACT 2010 or higher.  
This will let you utilize the Opportunity to 
Invoice features discussed later in the user 
guide. 

Enter in the login and password information 
for an ACT user that has administrator 
privileges. 
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Here is a list of the fields built by the QSalesDat a BUILD FIELDS program. 
 

Field Name Field Description Field Name Field Descr iption 

QB_InternalID Stores the QuickBooks unique ID STTotal 
Lifetime Sales total for data in 
the QB Transactions Tab 

QB_PrimaryContact 
Tag ACT contact for Contact Data 
Sync with QuickBooks ST AvgSaleAmt 

Avg Sales Amt for data in the 
QB Transactions Tab 

STLastInvoiceDate Last Invoice Date QB_0-30 A/R Balance 0-30 days 

STFirstInvoiceDate Date of First Invoice that exists in the 
QB Transactions Tab 

QB_31-60 A/R Balance 31-60 days 

STcur-01 thru 
STcur-12 

Current Year Monthly Totals QB_61_90 A/R Balance 61-90 days 

STcur-YTD Current Year YTD Sales QB_91 A/R Balance 91-120 

STprev-01 thru 
STprev-12 

Previous Year Monthly Totals QB_121 A/R Balance 121 + 

STprev-Total Previous Year Total Sales QB_Credit Limit QB Credit Limit 

STprev-YTD Previous Year YTD Sales QB_Past Due Total QB Past Due Total 

STprev2-01 thru 
STprev2-12 

2 Years Ago Monthly Totals QB_Terms QB Terms 

STprev2-Total 2 Years Ago Total Sales QB_Total Balance QB Total Balance 

STprev2-YTD 2 Years Ago YTD Sales QB_Account Number QB Account Number 

STprev3-01 thru 
STprev3-12 3 Years Ago Monthly Totals QB_Rep QB Sales Rep 

STprev3-Total 3 Years Ago Total Sales QB_Type QB_Type 

STprev3-YTD 3 Years Ago YTD Sales QB_Price Level QB Price Level 

STprev4-01 thru 
STprev4-12 4 Years Ago Monthly Totals QB_Last Payment Date QB Last Payment Date 

STprev4-Total 4 Years Ago Total Sales QB_Last Payment Amt QB Last Payment Amount 

STprev4-YTD 4 Years Ago YTD Sales   

    
 
The QSalesData program will build Custom Table in ACT called QSALESDATA and the associated fields 
to store the Invoice Detail information on the QB Transactions tab in ACT. 
 
STprev3 and STprev4 field sets get built when you choose the Years 4/5 option in our Build Fields 
program. 
 
The Opportunity section of the build fields and QSalesData will build the following fields in the Opportunity 
table of ACT: 
 
QB_QBID QB ID of the ACT contact linked to this Opportunity 
QB_TransID QB Transaction ID when a QB Transaction is created from the Opportunity 
QB_Type The type of QB Transaction created (Invoice, Estimate, Sales Order, Sales Rcpt) 
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ADDING THE QB DATA TAB TO YOUR ACT LAYOUT – STEP 3 OF INSTALL 
CHECKLIST 
 
Now that the fields have been added to ACT, you can use our QSalesData Tab Installer to add the fields 
to your ACT layout. 
 
Here are the steps to run our QSalesData Tab Installer. 
 
1. This utility will take the layout file you select and save a copy of it with a _QB at the end, it will then 

add a QB Data tab and fields to your layout. 
2. Go to Tools > QSalesData Tab Install, then choose “current layout” or pick a different layout. 
3. You should see a message stating that the Operation Completed Successfully and the layout will 

refresh to the _QB version and it should now instruct you to go to Tools > Design Layouts > 
Contacts.  If you don’t get the message, and the layout doesn’t refresh, close out of ACT and go back 
in and switch to the new layout  with the _QB at the end. 

4. Go into the Layout Designer as instructed, click on the QB Data tab once you are in the layout editor, 
and click anywhere in the tab area to add the fields to the layout. 

5. It will let you know when it is completed.  At this point simply close and say “yes” to save the layout.  
 
Here is what the new QB Data tab will look like on your layout after using our Tab Installer program: 
 

 
 
 
 
NOTE:   When you exit out of the Layout Designer, you may receive an “Object Reference Error” a couple 
of times.  You can ignore this error and click OK.  There is an ACT issue with older versions of ACT! 
refreshing our QB Transactions tab after exiting out of the layout designer.  You don’t need to worry about 
this error; it won’t affect anything. 
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SET YOUR QSALESDATA PREFERENCES 
 
Starting with QSalesData version 2.0.7.9, a Preferences tab was added to the Tools > QSalesData Import 
set of options. 
 
Here are the current preferences you can set in version 3.1 of QSalesData 

 
 
 
Auto-Link Companies to Contacts:  This 
preference lets you choose whether you want 
other contacts and Company records to be 
automatically linked to the same customer in 
QuickBooks if they are not currently linked.  
This only applies if you are using Company 
Records in ACT.  With this feature turned on, if 
you link one contact in ACT to the customer in 
QuickBooks, the next time a QSalesData 
transaction sync occurs, the associated 
Company record and any other contacts linked 
to that company will also be linked to the same 
customer in QuickBooks.  This functionality 
was automatically ON in prior versions of 
QSalesData, but some of our customers 
requested the ability to turn this functionality 
off.  If you want to turn off this auto-link 
functionality, simply uncheck the Enable Auto 
Link checkbox. 
 
 

Auto-Link Job Transactions to Customer:   This option only applies to customers that use the “Jobs” 
feature of QuickBooks.  If you have this option ON, then all job transactions in QuickBooks will “roll-up” 
and appear under the customer record in ACT.  If you have this feature turned off, then only transactions 
at the customer level will appear, and job transactions will be ignored in the transaction sync process.  
This “roll-up” feature was automatically built into prior versions of QSalesData, but some of our customers 
requested the ability to turn this functionality off. 
 
Default Name Format:   This option only applies to situations where you are using our QB Create/Link 
feature to add a new customer to QuickBooks and the record in ACT has a blank Company field.  
Meaning that the record is an “individual/person” rather than a “company”.  This lets you set your default 
preference to either Lastaname, Firstname or vice versa. 
 
Include Pending Invoices:   Check this option to include Pending Invoices in the Last Invoice Date and 
Past Due Balance fields calculations. 
 
Individual Contact Data Sync:   Check this option if you would like to include the Contact/Email fields 
when you use the ACT > QB button on the QSalesData toolbar to perform a Contact Data Sync for an 
Individual contact. 



Effective Solutions – QSalesData User Guide   -   Version 3.x 

  8

SET YOUR FIELD MAPPING – STEP 4 OF INSTALL CHECKLIS T 
 
It is important to configure your field mapping in the QSalesData product so that features within the 
product function properly.  You only need to do this once, it is a system wide setting.  You don’t need to 
configure this on each workstation. 
 
The following functions in QSalesData utilize the Set Mapping configuration: 
 

1. When creating ACT records from QB  (QB Link Wizard) 
2. When creating new QB Customers from ACT records (QB Create/Link button) 
3. Customer Data Sync option to sync field data between ACT and QuickBooks 

 
 
Here is how you configure your field mapping in the QSalesData product: 
 
1. From ACT, go to View > Contacts and then go to Tools > QSalesData Import 
2. Click on the SET MAPPING button.  You will get the following window.  Click on the RESET TO 

DEFAULTS to apply the default mapping.   
 

  
 
3. When you have completed mapping configurations, click on the CLOSE button and your mapping 

changes will be saved. 
 
 
 
 

The top 2 lines of the mapping 
are special.  Only change these 
if you have renamed your 
Company and Contact fields in 
ACT.  Otherwise leave them set 
to Company and Contact. 

You can go ahead and make 
adjustments to other fields if 
you have custom fields in ACT 
that need to point to fields in 
QB.  Simply click on the 
pulldown to pick from a list of 
ACT fields. 
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MAP QUICKBOOKS CUSTOM FIELDS TO ACT! 
 
If you have created custom fields in QuickBooks at the Customer or Item level, you can use QSalesData 
to map them back to ACT!.  If you haven’t setup any custom fields in QuickBooks, you can skip this 
section.   
 
Note, the sync of this data is 1-way, from QuickBooks to ACT.  You will need to maintain the field data in 
QuickBooks, and the information will sync back to ACT each time your Transaction Sync runs, or you hit 
the Refresh Data from QB button. 
 
Here is how to map your QB Custom fields to ACT: 
 
1. Go to Tools > QSalesData Import in ACT 
2. Click on the SET MAPPING button 

3. Click on the DETECT CUSTOM FIELDS button in the lower left of the screen 
4. When complete, you will get a message stating that the “Custom Transaction Mapping Set” 

5. If you only have custom fields at the Item level, you are done.  The next time you run a transaction 
sync, or a Refresh from QB, it will add your custom field information to the data on your QB 
Transaction tab. 

6. If you have custom fields at the Customer Level in QB, scroll down within the Set Mapping window 
and you will see your QB custom fields.  This version can see the first 10 custom fields in QuickBooks 
depending on your version of QuickBooks.  You will need to map these fields to fields in ACT.  See 
the screen shot below.  Note, you need to have fields built in your ACT database (Tools > Define 
Fields) to map your QB custom fields to.  QSalesData will not build those ACT fields for you. 

 
 

7. Once you have the QB custom fields mapped to fields in ACT, simply click on Close.   
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8. Close out of ACT and go back in to refresh your map ping.   The next time you run a Transaction 
Sync, or you click on the Refresh from QB button, it will bring the custom field data over from QB to 
ACT.  Custom field data will show up at the contact level in ACT, and also at the Transaction Detail 
level.  See screen shots below. 

 

 
 

 
 
 

 
 

 
 
 
 
 
 

 

 

Custom Field Data from 
QB will synchronize down 
to the mapped ACT fields 
each time a Transaction 
Sync runs or you use the 
Refresh from QB feature 

 

Custom Field Data at the Item 
level in QB will synchronize 
down to transactions in the QB 
Transactions tab when you 
double click on a transaction to 
see the details. 
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QB CUSTOMER LINK WIZARD – LINK ACT RECORDS TO QB  S TEP 5 OF 
INSTALL CHECKLIST  

Now that the fields are built and ready to go in the ACT 
database, we can begin linking records between ACT and 
QuickBooks.  With most ACT! databases, you will be linking 
ACT! Contacts with QuickBooks customer records.  If you are starting out with a brand new ACT 
database, you can skip ahead to the Create from QB feature.  
 
Here is how you can link records in a batch mode: 
1. Have the appropriate ACT and QuickBooks database s open on your computer. 
2. In ACT go to TOOLS > QB CUSTOMER LINK WIZARD 
3. Pick either the “Company Linking” or “Contact Linking” tab as your method, and then click on the 

LOAD DATA button.  If you don’t use Company Records in your ACT database, you can perform your 
linking at the Contact level.  Most people will link records at the Contact Level.  You will get a screen 
like the one below: 

4. Your QuickBooks may start flashing at this point,  if so it is prompting you to configure the 
application certificate.  Refer to the next page for configuring the certificate, and then come back here 
to complete the linking. 

Note:  The list displayed will only show you Company and Contact Records that are not yet linked to 
QuickBooks. 
 
Contact Linking 

 
 
5. The Linking program will compare all Contact Records in ACT to the QB Customer list.  Where an 

exact match is found, it will set the action to LINK.  The action will be set to SKIP if no matching 
record is found.  The program ignores all Quickbooks customers that are marked “inactive”.  If you 
would like to manually link a record that the program didn’t find a match on, simply double-click on the 
area that it says “Double Click to Choose”.  A box will pop up to allow you to manually search for a 
match and then link.  You can also adjust the Field Match Settings to use other data in ACT and 
QuickBooks to match on. 

6. Once you have your Links defined, click on the PROCESS button and it will run through the records 
and link them to QuickBooks. 

Linking at the Contact level 
also lets you filter down to just 
the Current Lookup 

If you use Jobs in Quickbooks 
and want to link ACT Records 
to Jobs, click the Include Jobs 
checkbox. 
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CONFIGURING YOUR QUICKBOOKS CERTIFICATE 
NOTE:  If you have a multiple user install, you should only be prompted for the certificate once.  Once 
QuickBooks has the certificate on file, all other machines with QuickBooks should not get prompted. 
 
The first time the QSalesData program attempts to talk to your QuickBooks program, typically when you 
run the Link Wizard the first time, you will be prompted to fill out some application certificate information.  
You will get a screen similar to the one below. 
 

 
 
When you get the digital certificate 
message, Click on YES. 
 
 
 
 
 
 
 
 
 
 
6. After you click on YES, you will get the following 

window.  Click on DONE and your link to QuickBooks 
has been established.  The QSalesData product will 
now be able to talk to QuickBooks.  You can close out 
of the QB Link Wizard window. 

 
 
 
 
 
Once completed, you can return to the QSalesData application and continue. 

Click on the Yes – Always 
option, select the user with 
Administrative rights and 
click on Continue. 
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PREPARING YOUR CUSTOMER RECORD DATA IN QUICKBOOKS 
 
If you plan on transferring QuickBooks Customer records from QuickBooks into ACT, you want to make 
sure that your data is filled in appropriately in QuickBooks so that it can map properly into ACT. 
 
Note:  This is only important if you are going to p ush field data from QB to ACT or use our Create 
from QB function.  If you are going push contact da ta syncs from ACT to QB, ignore this section. 
 
Minimum requirements for an Individual Person recor d in QuickBooks 
For a Person record in QuickBooks, you need to at least have the Contact field filled out, and the Contact 
name needs to match the first line of the Bill To address exactly. 

 
 
Minimum requirements for a Company record in QuickB ooks 
For a Company record in QuickBooks, you need to at least have the Company and Contact fields filled 
out.  The top of your billing address should match the Company, Contact or both so they don’t get pushed 

to ACT as Address lines. 
 

If you have Individual People 
setup as Customers in 
Quickbooks, you need to have 
them setup like the screen shot 
to the left.  At a minimum, you 
need to have the Contact Name 
field filled out, and the first line 
of the Bill To address needs to 
match the Contact Name. 

For Company records in 
Quickbooks, you should have 
both the Company and Contact 
fields populated.  QSalesData 
compares the top lines of the 
Bill To address to the Company 
and Contact fields in QB, and if 
they match, it will know that it is 
not an Address line and skip it. 

Either style will 
work for a Bill To 
address, just as 
long as the 
Company and/or 
Contact data 
matches data in 
the Company 
and/or Contact 
fields. 
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QB CUSTOMER LINK WIZARD – CREATE FROM QB FEATURE  S TEP 5 OF 
INSTALL CHECKLIST 
 
If you are starting with a brand new ACT! database, you can 
use this feature to push all of your QuickBooks customers into 
ACT.  There is a tab on the QB Link Wizard called Create 
from QB  that lets you take records from QuickBooks and make them records in ACT!. 
 
Note:  You will want to confirm that your Field Map ping is set properly before performing this 
step.  Go to Tools > QSalesData Import and click on  the SET MAPPING button.  You also want to 
verify that your QB Customer records are setup appr opriate, refer to the previous section called 
“Preparing your Customer Record Data in QuickBooks” f or more information. 
 
1. In ACT, go to Tools > QB Customer Link Wizard, click on the Create from QB tab. 
2. If you have a large QuickBooks database (greater than 5,000 customers), you can use our Enable 

Chunk option at the bottom of the screen to pull in smaller sections of the QuickBooks customer list.  
Simply click on the Enable Chunk checkbox, and provide a start and end range, ie. Starting With = A 
and Ending Before = F.  That will bring in all customers that start with A thru E. 

3. Click on the Load Data button when you are ready to lookup the Customer record from QuickbBooks.  
It will give you a list of all of the QuickBooks Customer Records that are not linked to records in ACT.  
The assumption here is that these QuickBooks records should be added to ACT!. 

 

 
 
4. You can click on the CREATE button and the contact records will be created in ACT! using the 

information from the QB Customer records.  The new records in ACT! will automatically be linked to 
the appropriate record in QuickBooks as part of this process. 

5. When the contact creation process is complete, you will get the message in the lower left status 
section: 

  
 
Now that you have records linked between ACT and QuickBooks, you are ready to run our Transaction 
Sync program to import data from QuickBooks into ACT. 
 

If you have a large QuickBooks 
file (> 5,000 customers) you can 
use our Enable Chunk feature 
to bring over the customer 
records in smaller batches. 

If you use Jobs in QuickBooks, 
and would like to bring the jobs 
into ACT as Contact records, 
then select the Include Jobs 
checkbox. 
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QB VENDOR LINK WIZARD  
 
New with QSalesData version 2.0.6.8 is the QB Vendor Link 
Wizard.  This feature works just like the QB Customer Link 
Wizard explained on the previous pages. 
 
You can use the QB Vendor Link Wizard to: 
 

- Link ACT Vendor records to QuickBooks Vendor records in mass 
- Create new ACT records from existing QuickBooks Vendor records in mass 

 
 
From ACT, go to Tools > QB Vendor Link Wizard to utilize these features.  Refer to the detailed 
instructions on the QB Customer Link Wizard for functionality descriptions. 
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TRANSACTION SYNC – IMPORT QB TRANSACTIONS INTO ACT STEP 6 OF 
INSTALL CHECKLIST 
 
Now the fun part, let’s get some QuickBooks data into ACT!  
Follow the steps below to pull in sales transaction data from 
QuickBooks into the linked records in ACT.   
 
 
Here is a diagram of what happens when you run the Transaction Sync Process: 
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How to run a Manual Transaction Sync 
 
1. Make sure that the appropriate ACT and QuickBook s databases are open on your computer. 
2. In ACT go to TOOLS > QSalesData Import.  The following window will be displayed. 
 

  
 
3. If you are importing for the first time, we recommend setting your “Days Back” number far enough to get all 

of your transactions from QuickBooks and pull them into ACT so that the First Invoice and Lifetime Sales fields 
will populate with the appropriate data.  That will match up with the Sales Totals fields you have in the 
database, and give your ACT users the information they need.  Once you have all invoices in the 
database, you can pull in just new information from QuickBooks by using the Filter Range option. 

4. Once you have your date parameter specified, click on the TRANSACTION SYNC to begin the 
import.  The Status section in the lower left will give you progress updates, and let you know when the 
process is complete. 

5. Once complete, you can go to the QB Transactions tab on any linked contact to see the transactions 
that were imported. 

 
Once you have manually imported the data, you can install the QB Transaction Sync program on your 
server computer to schedule automatic nightly transaction imports.  See the instructions for installing and 
configuring the QTransactionSync module  (Nightly Transaction Sync) later in this manual. 

 
The first time you import data, it is a 
good idea set your “Days Back” number 
far enough to get all of your transactions 
from Quickbooks and pull them into ACT.  
So if you have been using Quickbooks 
for 10 years, you should set your Days 
Back = 3065   
 
Click on the TRANSACTION SYNC 
button to start the import. 
 
After you have all of your data over, you 
can reset your Days Back to 5, 5 and 
180, like the screen shot displays, or 
obviously change it to fit your situation so 
it only searches for new QB data to bring 
over. 
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INSTALLING QSALESDATA ON THE USER WORKSTATIONS 
 
1. Once you have your main database setup with the QSalesData fields, layout and data imported, you 

can install the QSalesData program on the other workstations that are going to be using the features. 
2. Simply install the QSalesData program on each workstation.  You can go back to the Installing the 

QSalesData software section of this guide for reference, and install the program on the appropriate 
workstations. 

3. Once installed, you will be prompted to enter a Serial Number and Register QSalesData on each 
workstation.  Each workstation requires a separate serial number to register QSalesData. 

4. Once all of the workstations have QSalesData installed and registered, the QB Transactions tab plus 
the QSalesData toolbar will appear in ACT and you will be ready to go. 
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INSTALL AND CONFIG THE NIGHTLY QTRANSACTIONSYNC MOD ULE 
 
The QTransactionSync program allows you to configure automatic background imports of QuickBooks 
Sales data into ACT.  The computer running the QTransaction Sync program will also require a 
copy of the QSalesData program licensed and registe red on the computer.    Note: We recommend 
manually importing your full set of QuickBooks data into ACT first using the Manual Transaction Sync 
process, before scheduling your automatic background synchronizations. 
 
1. Go to the computer that you would like to run your nightly QSalesData nightly imports.  Note that the 

machine you choose needs to have both ACT! and QuickBooks installed and needs to be able to 
login to both the ACT and QuickBooks databases.  You will obviously need to leave this machine on 
overnight as well. 

2. Go to the www.QSalesData.com website and go to the Download / Install link.  Download the 
QSalesData Transaction Sync program.  Click on RUN when prompted. 

3. On the Welcome Screen, click on NEXT. 
4. Read the License Agreement and click on the appropriate button to continue. 
5. Install to the default folder and click on INSTALL. 
6. Click on FINISH, the install is complete.  Two new icons will now exist on your Windows Desktop. 

a. Effective Solutions QB Transaction Sync Config :  this is the program that lets you 
configure the synchronization parameters between ACT and QuickBooks 

b. Effective Solutions QB Transaction Sync :  this is the program that runs the 
synchronization process using the configuration settings you configured using the config tool. 

7. Double-click on the Effective Solutions QB Transaction Sync Config Icon.  The Databases to Sync 
Transactions window appears. 

8. Click on the ADD button.  You will get the following dialog box.  Fill out the information.  We 
recommend setting your Sync to the Last 180 days to cover any old invoices that may have 
outstanding balances. 

 

  

Select your ACT database and enter 
in your ACT login information. 

Select your Quickbooks database. 
 
This path needs to be the same path 
you use to open the file from 
Quickbooks and can’t be a UNC path.  
Needs to use a drive letter in path. 

Set your Days Back parameters. 
 
We recommend using the settings on 
the screen shot displayed: 7, 7. And 
180. 

Refer to the “Set your QSalesData 
Preferences” section of the manual to 
understand what these two 
checkboxes control. 
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9. Don’t open your QuickBooks program until after y ou have selected your QuickBooks file 

using the browse button, otherwise you may get a “F ile is in Use” message.  If that is the case, 
have everyone close out of QuickBooks, and hit the open button to select the QuickBooks file.  
After you have selected the QuickBooks file, you th en need to login to QuickBooks as the 
admin account in single user mode.  The configurati on tool will need the QuickBooks program 
open to perform its initial configuration. 

10. Click on the SAVE button. 
11. You will see the status in the lower left say “Updating Configuration, Please Wait” and after a few 

seconds your QuickBooks program should start flashing, switch over to QuickBooks and the following 
window should appear. 

 

 
 
12. Select the bottom option to allow access, even if QuickBooks is not running, and select a user that 

has administrator privileges in QuickBooks .  Click on Continue. 
 

Select the bottom option to allow 
access, even if Quickbooks is 
not running, and select an 
account that has 
administrative privileges in  
Quickbooks.  
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13. When asked “Are you sure you want to allow access?”, click YES. 
 

 
 
14. You will then get a confirmation window, like the one below.  You can click on DONE. 
 

 
 
15. Going back to the EFF Configuration tool, the window status should now say Configuration Settings 

Saved.  Just like the window below. 
 

 
 
16. You can click on the EXIT button, and your configuration will show up in the list.  Click on EXIT on this 

window as well. 
 

 
 
 



Effective Solutions – QSalesData User Guide   -   Version 3.x 

  22

 
17. You are now ready to test the background synchronization you just configured.  Add a new 

transaction to QuickBooks that doesn’t exist in ACT yet.  Close out of ACT and QuickBooks.  Go to 
your Windows Desktop, and double-click on the EFF QB Transactions Sync icon to run the 
background sync process. 

 

 
 
18. When the background sync process is running, you will see a status window on the screen, like the 

one below. 
 

 
 
This background process will import QuickBooks sales data for the “Last XX Days” that you specified in 
the configuration tool.  It will also update the Sales Total fields in ACT where necessary. 
 
When the background sync process is complete, the window will simply disappear from the screen. 
 
19. You can now go into ACT and verify that any new transactions have been imported. 
20. The last step is to add the EFF Transaction Sync program to the Windows scheduler on this machine.  

Go to Start > Programs > Accessories > System Tools and select the program called Scheduled 
Tasks . 

 
 
 
 
Note, there is a video in our QSalesData Online Video Library (www.qsalesdata.com/onlinevideos)  that 
takes you thru how to setup the Nightly Sync Program on a Windows 2008 Server or Windows 7 
machine.   The Task Scheduler is completely different in Windows 7 and Windows 2008 server.
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You will get a window similar to the one below. 

 
 
21. Double-click on the ADD A SCHEDULED TASK item and hit NEXT at the first window.  
22. Click on the BROWSE button and go to C:\Program Files\Effective Solutions QB Batch Sync and 

select the file called QB-BatchTransaction and click on the OPEN button. 
23. You will now be able to select how often to run your background imports.  Select how often you would 

like to run the background import and click on NEXT.  

 
 
24. The next screen lets you select a start time and some other options for running the program.  In the 

example below, I want my background sync to run every week day at 11:00pm.  Select the 
appropriate options for your situation and hit NEXT. 
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25. The last step is to provide Windows Scheduler the appropriate credentials to run this task.  You will 

get a screen like the one below.  We recommend using a Windows Administrator account to run the 
task.  Enter in the credentials and hit NEXT. 

 
 
26. You will get a final screen summarizing the scheduled task you just setup. 

 
 
27. Click on the FINISH button.  You will be returned to the Scheduled Tasks window, and your new task 

that you just created should appear in the list. 

 
 
28. It is a good idea to test the new task you just created.  Right-click on the task item in the list and 

select the RUN option.  The background sync window should pop up and run.  If so, you are all set.  If 
not, right-click on the task and go to Properties and check your settings and credentials.  
Congratulations, you have now setup your background sync to run automatically. 
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USING THE QB TRANSACTIONS TAB  
 
The QB Transactions tab will display all of the QuickBooks transactions imported for a Contact or 
Company linked to QuickBooks.  If you are working with a Contact linked to a Company, the data in the 
QB Transactions tab will be identical, whether you are on the Contact record or the Company record. 
 
Note:  The QB Transactions and QB Items Tabs will only display on workstations that have QSalesData 
installed. 
 
QSalesData lets you import the following transaction types for customer records in ACT: 
 

 
 
Here is what the data on the QB Transactions tab wi ll look like:  
 

 
 
 
Using the Filters on the Transactions Tab 
 
You can filter items on the Transactions Tab by either Transaction Type or by Date Range.  See the 

example shots below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

You can make column display adjustments by right-clicking 
on the column headers and selecting COLUMN CHOOSER.  
You can also resize and click-and drag columns, and click on 
any column header to sort by that column.  You can remove 
columns by clicking and dragging them straight up and off of 
the tab. 

You can use the Transaction 
filters to filter your list by date 
or transaction type. 

Note: there is no transaction detail 
for Payments.  Meaning if you 
double-click on a payment, 
nothing will happen.  You can use 
the GOTO feature for all 
transactions, including Payments. 

You can click on the GOTO button 
to pull up the transaction in 
Quickbooks.  You need to have 
QB open for this feature to work. 
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Using the Grouping option on the QB Transactions Ta b 
 
Here is an example of what the new grid style looks like when grouping by a column: 

 
 
 
To see the detail of any Invoice, simply double-click on the Invoice line and you will get a screen display 
like the one below: 
 

 
 

Drag a column to this section to group by the data in that column.  
Click on the “+” sign to expand each grouping to see details. 
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Using the GOTO button on the QB Transactions Tab 
 
If the user has access to QuickBooks on their computer, they can 
utilize the GOTO button on the transactions tab to pull up the 
transaction in QuickBooks. 
 

1. Highlight the appropriate transaction in the QB Transactions list 
2. Make sure that QuickBooks is open 
3. Click on the GOTO Button, you will be taken to the transaction in QuickBooks 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 
 
 

 
 

Select a transaction, click on 
the GOTO button, and 
QSalesData will pull up that 
specific transaction in 
Quickbooks! 
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CONVERT ESTIMATES AND INVOICES FROM THE QB TRANSACT IONS TAB TO 
OPPORTUNITIES IN ACT 
 
In some cases you may want to continue to create Estimates in Quickbooks because your salespeople 
are comfortable with the process, but you also want to be able to convert the estimate to an Opportunity 
in ACT.  We added a Convert to Opportunity button  to the QB Transactions Tab in ACT to do just that. 
 
You can simply select an Invoice, Estimate or Sales Order from the QB Transactions list and then click on 
the CONVERT TO OPPORTUNITY button and it will take the information from the transaction and build 
an associated Opportunity for it in ACT. 
 

 
 
After you click on the CONVERT TO OPPORTUNITY button, it will take you to the Opportunity that was 
just created so you can enter in an Estimated Close date and Stage for the Opportunity.  The screen shot 
below is what the Opportunity will look like after it has been created. Notice that the Line Items from the 
QB Transaction have been transferred to the Products/Services section of the Opportunity, and the 
Opportunity Total amount should match your QuickBooks transactions. 
 
From this point the user can manage the Sales Opportunity in ACT until it is sold.  The BackOffice user 
that has QuickBooks on their computer can also click on the EDIT TRANSACTION IN QB button to pull 
up the Estimate in Quickbooks and quickly convert it to an Invoice if appropriate. 
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USING THE QB ITEMS TAB 
 
QB ITEM tab in ACT lets you see sales data by QB It em number.   Use this tab to see what items the 
customer has purchased.  You can click on any of the column headers to sort by that data.You are able to 
take the Item Number column add move it to the Group By section to group sales by Item Number.   
 

 
 
Grouping your Item Information:  You are able to take the Item Number column add move it to the 
Group By section to group sales by Item Number.   

 
 
 
Export your Item Data to Excel:   In some cases you may want to export your customers Items 
purchased to Excel for further analysis.  We have added a Export to Excel button to the QB Items tab.  
Click the button the the Item data for the current contact will be exported to Excel. 

 

 

Drag the Item Number column to this section to group by the data 
in that column.  Click on the “+” sign to expand each grouping to 
see details. 
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USING THE LOOKUP ITEM FEATURE 
 
This button gives the QSalesData user the ability to search through the QB Items tab and lookup all 
customers that purchased a particular QB Item for a specific date range in ACT.  This then gives you the 
ability to up-sell or cross-sell to these customers from ACT using an email blast, mail merge, label print, 
etc.  You do not need to have QuickBooks on your computer to use the Lookup Item feature. 
 
The LOOKUP ITEM button will show up both on the QSalesData toolbar and within the QB Items tab. 

 

 
 

 
 

When you click on the LOOKUP ITEM button, you will get the following dialog box: 
 

 
 

So, in this example, I want to pull up all customers that bought a Dell Server between 1/1/2010 and 
6/4/2010.  When you click OK, you will get a list of contacts that match the criteria in ACT.  They become 
your “current lookup” in ACT.  You can then perform your marketing in ACT from this list. 
 

 

Type in all or part of the QB item name 
to search for.  It will do a “contains” 
search. 

You can also specify a date range for 
when the QB Item was purchased. 
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CREATING A QUICKBOOKS CUSTOMER FROM A RECORD IN ACT ! 
 
If a prospect in ACT becomes a customer, the QSalesData 
product gives you a quick way to add them to QuickBooks as 
a customer.   If you get a brand new customer, you want to 
enter them into ACT first and then use this process to add them to QuickBooks. 
 
Note:  You will want to confirm that your Field Map ping is set properly before performing this 
step.  Go to Tools > QSalesData Import and click on  the SET MAPPING button. 
 
Here is how you create a QuickBooks customer from a record in ACT: 
 
1. Make sure that the appropriate ACT and QuickBook s databases are open on your computer. 
2. Pull up the appropriate record in ACT!  If you just created a new Contact in ACT, make sure to hit the 

SAVE button on the toolbar first =  to save the record to ACT. 
 

3. Click on the  button on the ACT! toolbar. 
4. You will get the following prompt.  Note that you can also create a Job in QB from this screen. 
 

 
 
5. Choose CREATE CUSTOMER, and you get the next window.  If your ACT contact has a Company 

name, the window will default to that.  If you are dealing with an Individual, it will default to the 
Contact LastName, FirstName.  You can also pick from the pulldown, or type in your own Customer 
name. 

 
 

6. Click on CREATE to create the QB Customer.  The QSalesData program will use your SET 
MAPPING field settings configured earlier in the Quick Start Guide.  (Tools > QSalesData Import > 
Set Mapping button)  

 
7. The end result is a new Customer in QuickBooks, and the record in ACT will be automatically linked 

to the record.  You will be prompted with the following message which gives you the option to jump to 
the customer record in QuickBooks to enter in additional customer setup information if you choose. 

 

 
 



Effective Solutions – QSalesData User Guide   -   Version 3.x 

  32

LINK A SINGLE ACT! RECORD TO AN EXISTING QUICKBOOKS  CUSTOMER 
 
If you have a single record in ACT! that you want to link to 
QuickBooks, you don’t have to use the QB Link Wizard.  You 
can quickly attach the record using the QB Create/Link 
Customer button. 
 
1. Make sure that the appropriate ACT and QuickBook s databases are open on your computer. 
2. Pull up the appropriate record in ACT! 

3. Click on the  button on the ACT! toolbar. 
4. You will get the following window that appears.  Click on the LINK button. 

 

 
 
5. QSalesData will use the ACT Company and Contact fields to search for a match in QuickBooks.  If it 

finds a match, it will display the matching QB records in the list.  Otherwise you can type in what to 
search for in the QB Customer list and click on the SEARCH button. 

 

 
 
6. Click on the LINK button when you have found the QB record you want to link to.  You will get the 

following message when the record link is complete. 
 

 
 
 

If a match is found, it will be 
displayed in the list.  Otherwise 
you can type in what to search for 
and click on the Search button.  It 
will do a “contains” type search, 
meaning it will look for the text 
anywhere in the Quickbooks 
Customer Name.  When you find 
the QB record you want to link to, 
select it from the list and click on 
the LINK button. 
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CREATING QUICKBOOKS TRANSACTIONS FROM ACT! 
 
The QSalesData product gives you the ability to create all of the 
major types of QuickBooks transactions from ACT! with the click 
of a button.   
 

 
 
1. Make sure that the appropriate ACT and QuickBook s databases are open on your computer. 
2. Pull up the appropriate record in ACT!  Note that you need to be on a contact record that is linked to 

QuickBooks for this feature to work. 
3. Select the appropriate Transaction Type (Invoice, Estimate, etc.) from the QSalesData toolbar in 

ACT!. 
4. You will be transferred over to QuickBooks, and a new transaction will window will be displayed and 

pointing to the appropriate customer record.  From there you can complete the transaction and hit 
SAVE & CLOSE. 

5. If you would like the new transaction to be transferred to ACT right away, you can jump back to the 
ACT record and click on the REFRESH DATA FROM QB button. 

 
 
 

Using the QSalesData toolbar in 
ACT, you are able to quickly create 

- Invoices 
- Estimates 
- Sales Orders 
- Sales Receipts 
- Receive Payment 
- Credit Memos 
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USING THE QUICK CONTACT SYNC BUTTON TO UPDATE A SIN GLE ADDRESS 
IN QUICKBOOKS (ACT > QB BUTTON) 
 
 
 
There is an ACT > QB button  on the QSalesData toolbar that allows the user to quickly sync the address 
information of the current contact with Quickbooks.  The new button is at the end of the QSalesData 
toolbar and allows you to select either ACT > QB or QB > ACT. When you click the button it will take the 
ACT address info and overwrite the customer info in Quickbooks, or vice versa.   
 
If you have made a change to the record in ACT, mak e sure to his the SAVE button on the toolbar 
before clicking on the ACT > QB button. 
 

 
 
When you click this button, you will be prompted with the following dialog box. 
 

 
 

When you click on YES the address information will be pushed in the direction you selected, and you will 
receive the following message when the process is complete. 
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CONTACT DATA SYNC PROCESS (UPDATING A BATCH OF ADDR ESSES IN ACT! 
AND QUICKBOOKS) 
 
The Contact Data Sync feature in QSalesData lets you push 
contact field information between ACT! and QuickBooks records 
that are linked.  You will be able to select which direction to push 
updates, and you will be able to run the updates on All Contacts or 
the Current Lookup in ACT!.  This feature works great if you make all of your customer field changes in 
either ACT! or QuickBooks.  You can then push them to the records in the other application. 
 
As a best practice, we recommend that a company decides where they are going to make all of their 
customer record changes, ACT! or QuickBooks, and stick to that procedure.  That will give you the 
flexibility to push all records, rather than having to do individual record pushes.  We recommend making 
all of your customer address changes in ACT and pus hing the changes to QuickBooks on a 
regular basis, like once a day or once a week. 
 
 
Here is a diagram of how the Contact Data Sync feat ure works: 
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Here is how to setup your system for the Contact Da ta Sync process: 
 
 
STEP ONE – Make sure the QB_PrimaryContact field is  accessible 
 
Make sure you added the QB_PrimaryContact checkbox field to your ACT! layout. 
 

 
 
STEP TWO – Check the QB_PrimaryContact box for reco rds you want to sync data with 
 
Pull up all of your ACT! contacts linked to QuickBooks by doing a lookup on the QB_InternalID field and 
searching for records that Contain Data. 

- Lookup > Other Fields 
- Set field to QB_InternalID and change operator to Contains Data 
- Click on OK 

 

 
 
You now have a list of all of the Contacts that are linked to QuickBooks.  Go through the list and check 
the QB_PrimaryContact box for the ACT! contacts that you would like to sync field information with 
QuickBooks customer records.  We recommend a 1-to-1 relationship, meaning that you should only select 
one ACT! contact for each QuickBooks customer. 
 
TIP:  When you are first starting out, it may be a good idea to pick 1 or 2 ACT! records as the 
QB_PrimaryContact and test your Data Sync to make sure your field mappings are appropriate for your 
ACT! database.  You can come back and select the other records later. 
 
TIP:  From the Contact List view, you can add the QB_PrimaryContact field as a column, and then use 
the EDIT MODE feature if you are on a newer version of ACT to quickly check the box for contacts. 
 
 
If you are an Advanced ACT user, you can use the EDIT > REPLACE feature to change the value of the 
QB_PrimaryContact field on multiple ACT records all at once. 
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STEP THREE – Run your Contact Data Sync Process 
 
TIP REMINDER:  When you are first starting out, it may be a good idea to pick 1 or 2 ACT! records as the 
QB_PrimaryContact and test your Data Sync to make sure your field mappings are appropriate for your 
ACT! database.  You can come back and select the other records later. 
 
Note:  You will want to confirm that your Field Map ping is set properly before performing this 
step.  Go to Tools > QSalesData Import and click on  the SET MAPPING button. 
  
Now that you have records in ACT! tagged as QB_PrimaryContact’s we can run a data sync between 
ACT! and QuickBooks.  Here is the procedure for the Contact Data Sync. 
 
1. In ACT, go to  Tools > QSalesData Import, and click on the Contact Data Sync tab. 
 

 
 
2. Pick the direction to sync QB to ACT or vice versa. 
3. Choose whether you want to sync all ACT contacts that are tagged as QB_PrimaryContact, or just 

the Current Lookup. 
4. If you want to include the Company, Contact and Email address fields in the sync, select the 

Checkbox at the bottom of the screen. 
5. When you are ready to sync, click on the SYNC button in the Contact Data Sync section. 
 
Data will be pushed in the direction you specified, and you will get a “Contact Sync Complete” message in 
the lower left of your screen. 
 
Note:  Only ACT records that are linked to QB, and have the QB_PrimaryContact field checked will 
be included in the Contact Data Sync process. 

 
You pick which direction you want 
the Data Sync to run. 
 
 
You pick whether you want to run 
on the current lookup in ACT, or 
using All Contacts. 
 
You can check the box to include 
the Contact and Email fields in the 
Data Sync. 

When you are ready to Sync 
Customer Data, click on the 
SYNC button. 
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CREATING A QUICKBOOKS VENDOR FROM A RECORD IN ACT! 
 
Starting with QSalesData version 2.0.6.8, you can now 
create Vendors in QuickBooks from records in. 
 
Note:  You will want to confirm that your Field Map ping is set properly before performing this 
step.  Go to Tools > QSalesData Import and click on  the SET MAPPING button. 
 
Here is how you do it: 
 
1. Make sure that the appropriate ACT and QuickBook s databases are open on your computer. 
2. Pull up the appropriate record in ACT! 
3. Click on the QB Create/Link Vendor option on the QSalesData toolbar in ACT! 

 
 
4. You will get the following window that appears. 
 

 
 
5. Click on the FIND MATCH button to make sure the record doesn’t already exist in QuickBooks.  It will 

attempt to match by Vendor Name.  If it finds a match, you will have the option to link to that record in 
QuickBooks.  If you get a NO MATCH FOUND message, you can go ahead and select the CREATE 
NEW QB VENDOR option to add the record to QuickBooks. 

 
6. Click on OK to create the QB Vendor.  The QSalesData program will use your SET MAPPING field 

settings configured earlier in the Quick Start Guide.  (Tools > QSalesData Import > Set Mapping 
button)  

 
8. The end result is a new Vendor in QuickBooks, and the record in ACT will be automatically linked to 

the record. 
 
 
 
 
 

From the QSalesData toolbar in 
ACT, click on the arrow to pull 
down the QB Create/Link 
Vendor option and select it. 
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LINK A SINGLE ACT! RECORD TO AN EXISTING QUICKBOOKS  VENDOR 
 
If you have a single record in ACT! that you want to link to 
QuickBooks, you don’t have to use the QB Link Wizard.  You 
can quickly attach the record using the QB Create/Link Vendor 
button on the QSalesData toolbar. 
 
1. Make sure that the appropriate ACT and QuickBook s databases are open on your computer. 
2. Pull up the appropriate record in ACT! 

3. Click on the  button on the ACT! toolbar. 
4. You will get the following window that appears.  Click on the LINK TO EXISTING QB Customer option 
 

 
 
5. Then click on the SEARCH button to search for an existing QuickBooks Vendor record to link to. 
 

 
 
 
9. Click on the LINK button when you have the appropriate QB Vendor record selected. 
 

If a match is found, it will be 
displayed.  Otherwise you can  
choose the SHOW ALL QB 
Vendors option to choose from the 
entire list of QB Vendor Records. 
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UNLINKING AN ACT! RECORD 
 
At some point you may want to unlink an ACT Record from QuickBooks.  To unlink a record, simply pull 
up that record in ACT and click on the appropriate button on the toolbar depending on if it is a Customer 
record or Vendor record. 
 

 
 
Then click on the LINK button and you will get the following message: 
 

 
 
 
Answer YES and the record will be unlinked.  When you unlink a contact all of the QB Sales Total and 
Related fields will be cleared as well.  The next time the QB import runs, the QB Transactions will be 
cleared for that record as well. 
 

CLEARING DATA ON THE QB TRANSACTION TAB 
 
In some cases you may have linked an ACT record to the wrong customer in QuickBooks, or you deleted 
a transaction in QB and you need to clear the data in the QB Transactions tab and resync the transaction 
data.  We have added functionality to the Clear Data button.  You can access the Clear Data function by 
going to TOOLS > QSALESDATA IMPORT in ACT.  You will get the following options: 

 

 
 

Once you clear the data, you can click on the REFRESH FROM QB button or run a Transaction Sync 
(Tools > QSalesData import) to bring down the data again from QuickBooks. 
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CONVERTING ACT! OPPORTUNITIES TO QB TRANSACTIONS  
 
This new functionality allows the ACT Sales User to create an Opportunity in ACT!, select QuickBooks 
Items from the ACT! product tab, and when the timing is right, the Opportunity can then be converted to a 
QB Transaction (Estimate, Invoice, Sales Order, Sales Receipt) with a click of a button. 

 
There is no easy way to update existing ACT Opportunities so they can be converted to QB Transactions.  
We recommend using this new process for all future Opportunities created. 
 
How to get the Opportunities to QB Transactions pro cess setup on your ACT! system: 

 

1. From ACT, go to Tools > QSalesData Import and click on the Build Fields button, and say YES 
when prompted. 

2. Check the box for Opportunity fields, enter in the ACT login info and click on the BUILD FIELDS 
button, and the specific Opportunity fields needed for QSalesData will be built. 

3. Close out of ACT and go back in after the Build Fields program has completed. 

4. Go to Tools > Design Layouts > Opportunity and add the following fields to the Opportunity 
Layout so you can see them on the Opportunity screen in ACT: 

 
 

Your ACT! 2010 system is now setup and ready to utilize the new Opportunity to QB Transaction 
features. 

 
Copying the QuickBooks Item list into the Product L ist in ACT! 

 
One of the key components of the process is having your QuickBooks Items listed in the ACT Opportunity 
Product list.  We have a function that copies your QB item list into the ACT Opportunity Product List. 
 

1. From ACT, go to Tools > QSalesData Import 

2. Click on the SYNC ITEMS button   in the lower right of the window. 

3. You will be prompted to Clear the Product list before syncing, we recommend saying YES to this.  
A status of “Updating ACT! Product List” will appear in the lower left while the QB Items are being 
copied down to ACT. 

4. When the process is complete, you will get a “Sync Complete” message.   

5. When complete, all of your QB items exist within the ACT Products list. 
6. To verify, you can go to the Opportunities section of ACT (View > Opportunities).  And then go to 

(Opportunities > Manage Product List) and that will pull up the product list in ACT. 

 
Note:  Each time you run the SYNC ITEMS function it will copy down any new QB Items and also make 
updates to existing QB Items that may have been changed (description, price).  The new nightly sync 
program will also have a checkbox to run the Sync Items every night as well. 
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Here is what the Product List looks like in ACT with the QB items copied down.  Notice that the Item 
Number, Item Description, and Price came down for all QB Items.  If you have Inventory Parts in 
QuickBooks, then the Cost will also come down into ACT.  We include the Item Number at the end of 
each Description/Name to keep them unique in the ACT product list. 
 

 
 
Creating an Opportunity in ACT! that can be convert ed to a QB Transaction 

First thing to note is the user/workstation that is creating the opportunity needs to have a QSalesData 
license in order for the process to work. 

1. Pull up the contact in ACT that you want to create an Opportunity for.  

2. Go to the Opportunities tab and click on the NEW OPPORTUNITY button 
3. ACT will jump you to the New Opportunity screen.  If the contact was linked to QuickBooks, than 

the QB ID number on the Opportunity will be filled in, otherwise it will say NOID. 
4. Go to the Products tab of the Opportunity and click on the ADD button. 

5. The first time you see this screen, you will have more fields than you need.  Click on the 
DISPLAY FIELDS button to adjust the fields that show up to match the list below: 
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6. When you click OK, your data entry screen will look like the one below.  This should work just fine 

for most companies, 

  
 

7. The user can click on the ADD button again on the Products tab to add more line items to the 
Opportunity. 

8. Below is an example of a Products tab that has multiple line items created in ACT. 
 

 
 

9. At this point the user can fill out any other fields related to the Opportunity (stage, process, etc) 
and manage that opportunity.  Once the Opportunity is sold, you will be able to convert it to a 
QuickBooks transaction. 

10. If the user wants to generate a quote from ACT, they can use the Create Quote feature 
(Opportunity > Create Quote).  The ACT quote template is pretty limited.  If you need more 
advanced quote template/merge functionality, we can recommend some 3rd party addons for you. 

 

 

Select your QB Item from the list.  
When you hit TAB, the Name and 
price will auto-populate.  Then update 
your quantity and you are done with 
entering this product in ACT.  This is 
the equivalent to a line item on an 
invoice in Quickbooks. 
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Converting an ACT Opportunity to a QB Transaction 

 

When the time is right (deal is sold, time to create estimate, etc.) you can quickly convert an Opportunity 
to a QuickBooks transaction. 
 

In order to perform this conversion, you need to be on a workstation that has QuickBooks Installed as well 
as QSalesData.  What will normally happen is the Salesperson will create and maintain the Opportunity in 
ACT, and a back office person that has QuickBooks on their computer will lookup Opportunities that are 
WON and convert them to QuickBooks transactions. 

 
Converting a Single Opportunity from the Detail Vie w in ACT! 

 
1. Pull up the Opportunity in ACT that needs to be converted. 
2. When you are on the Detail view of that opportunity, you will have a QSalesData toolbar with the 

following options for converting: 

 
 
3. Choose the appropriate conversion option. 
4. The QB transaction will be created and you will be prompted with the following window: 

 
 
5. If you choose yes, it will bring up the transaction in QuickBooks that you just created. 

6. In addition, the QB Trans ID and QB Trans Type fields are also updated for the opportunity, giving 
you a record that it was converted and what it was converted to. 

 

7. Once the Opportunity is converted, you can use the  on the QSalesData toolbar to 
pull up the transaction in QuickBooks. 
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Converting a Multiple Opportunities from the Opport unity List View in ACT! 

 

You also have the option of converting a whole chunk of 
opportunities all at once.  You could for example lookup all 
Opportunities that are WON, but have a blank QB Trans ID or QB 
Trans Type, meaning they haven’t been converted to QB Transactions yet. 
 
Here is how to convert from the Opportunity List  

 
1. Select the Opportunities from the list that you want to convert.  Notice the ones in the screen shot 

below don’t have a Trans ID or Trans Type, telling me they have not been converted yet. 

2. Click on the CONVERT TO button on the QSalesData toolbar, and select the type of QB Transaction 
you would like to create. 

 
 
3. When all of the Opportunities have been converted, you will get the following message. 

 
 

4. You will see that the Trans ID and Trans Type get filled in for each one created. 

5. Once the Opportunities are converted, you can use the  on the QSalesData 
toolbar to pull up the transaction in QuickBooks if necessary. 
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MOVING A QSALESDATA LICENSE TO ANOTHER MACHINE 

 
You may need to move a QSalesData install from one machine to another machine because you are 
replacing a machine, or you want to give the functionality to a different user. 
 
Here are the steps to deactivating a license and moving it to a new machine: 
 

1. Go to the machine that you want to remove QSalesData from 
2. In ACT!, go to Tools > QSalesData import and click on the LICENSING button.  You will get the 

following window.  Highlight your serial number, and paste it into a document for future reference. 
 

 
 

3. Click on the DEACTIVATE button to run the Deactivate process.  You will get the following 
window: 

 

 
 

4. Click on the DEACTIVATE button and your serial number will be deactivated on this machine via 
the Internet.  You will get a message saying the license has been deactivated and the serial 
number will be displayed so you can note it to use it on the new machine. 

5. You should go to Control Panel > Add/Remove Programs on the machine and remove the 
QSalesData program.  The serial number can now be used to register QSalesData on another 
machine.   

 

 
 


